Author Topic: Login from spell page bug  (Read 979 times)

Nathan

  • Mighty Duke
  • ****
  • Posts: 713
    • View Profile
Login from spell page bug
« Topic Start: September 28, 2011, 03:19:02 PM »
When I try to log in whilst viewing a spell (I was looking at this one), I get a few errors:

ErrorException [ Warning ]: Missing argument 1 for Info::view_spell()

ErrorException [ Notice ]: Undefined variable: id

ErrorException [ Notice ]: Undefined variable: id

An Error Was Encountered [ 500 ]

I've got the whole thing copied into a text file if you want me to send it to you.

Anaris

  • BM Dev Team
  • Exalted Emperor
  • *
  • Posts: 8136
    • View Profile
Re: Login from spell page bug
« Reply #1: September 28, 2011, 03:32:58 PM »
Yeah; when you log in from the spell-viewing page, it doesn't retain the spell ID, and the script has no fallback for a missing ID, so it just breaks.
Timothy Collett

"The only thing you can't trade for your heart's desire...is your heart." "You are what you do.  Choose again, and change." "One of these days, someone's gonna plug you, and you're going to die saying, 'What did I say? What did I say?'"  ~ Miles Naismith Vorkosigan

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8205
    • View Profile
    • BattleMaster
Re: Login from spell page bug
« Reply #2: September 28, 2011, 04:14:26 PM »
try now


Nathan

  • Mighty Duke
  • ****
  • Posts: 713
    • View Profile
Re: Login from spell page bug
« Reply #3: September 28, 2011, 05:28:17 PM »
Nope:

ErrorException [ Fatal Error ]: Unable to load the requested file: info/index.php

The debug text appeared in the middle of the page this time, with the banner, side links & login menu still visible.

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8205
    • View Profile
    • BattleMaster
Re: Login from spell page bug
« Reply #4: September 28, 2011, 06:02:45 PM »
aargh, wrong redirect. Now.


Nathan

  • Mighty Duke
  • ****
  • Posts: 713
    • View Profile
Re: Login from spell page bug
« Reply #5: September 28, 2011, 06:08:43 PM »
Takes me to the Introduction page, but I get the message: "You are not logged in or your session has expired. Please log in (again)."

Clicking "login" then lets me log in successfully.