Author Topic: Alpha Client Feedback  (Read 14838 times)

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #15: April 11, 2016, 07:29:40 AM »
Thank you. It should be more clear in the e-mail that this key is only for activating the account, it cannot be used to log in, yes?


Yes the UI is still primitive and everything. Working on it. Exit buttons and such are part of that.

Can you explain what you mean with the tables comment, maybe with a screenshot? Because for me they work fine.

Nosferatus

  • Testers
  • Mighty Duke
  • *
  • Posts: 1093
  • Too weird to live, too rare to die
    • View Profile
Re: Alpha Client Feedback
« Reply #16: April 11, 2016, 08:39:46 AM »
Yes the key given in the e mail itself is another key that you cant use.

here are the screen shots of the content extending under the main table which should hold the content.
Perhaps make a scroll bar?

http://postimg.org/image/o9hg177d7/
http://postimg.org/image/o3c1z18xt/

Also has none of the games are starting i cant test any further

(i accidently pmed you this...)
Formerly playing the Nosferatus and Bhrantan Family.
Currently playing the Polytus Family in: Gotland, Madina, Astrum, Outer Tilog

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #17: April 11, 2016, 11:22:31 PM »
Yes the key given in the e mail itself is another key that you cant use.

I've updated the texts to make it more clear, thanks for pointing it out.



Quote
here are the screen shots of the content extending under the main table which should hold the content.
Perhaps make a scroll bar?

There should be one. Strange.


Nosferatus

  • Testers
  • Mighty Duke
  • *
  • Posts: 1093
  • Too weird to live, too rare to die
    • View Profile
Re: Alpha Client Feedback
« Reply #18: April 12, 2016, 05:13:52 PM »

There should be one. Strange.

When i click hold and drag up and down, the content is scrolled up and down actually, but it doesn't stay in the table/window where it should. There is also no visible scroll bar.
Formerly playing the Nosferatus and Bhrantan Family.
Currently playing the Polytus Family in: Gotland, Madina, Astrum, Outer Tilog

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #19: April 12, 2016, 07:43:13 PM »
Confirmed. This is a bit tricky, not sure if I can fix it fast. I'm not sure I understand completely what the problem is.

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #20: April 14, 2016, 01:10:17 AM »
Build 4 is now available for download, much improved:

http://blackforest.lemuria.org/h/download


Tell your friends so we can get a test game or two started !

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #21: April 14, 2016, 08:37:31 AM »
Also, due to the glitches in selection with the last client, I have reset all families, so please log in with the new client and select a family again.

James

  • BM Dev Team
  • Mighty Duke
  • *
  • Posts: 986
  • WARNING: Outer Tilog is different...
    • View Profile
Re: Alpha Client Feedback
« Reply #22: April 14, 2016, 12:56:41 PM »
New client installed, family selected for the two towns. Nothing more to be done for now :(

Might be nice to be able to see how many players are being waited for once you've joined, so you can get an idea of when it's close to starting. But that's not important at this stage :)
WARNING: Outer Tilog is different...

Nosferatus

  • Testers
  • Mighty Duke
  • *
  • Posts: 1093
  • Too weird to live, too rare to die
    • View Profile
Re: Alpha Client Feedback
« Reply #23: April 14, 2016, 05:16:14 PM »
while waiting for the games to start, i cannot see how many more players are required to start it.
It might be useful to show this, so i can see how much longer it could take or how many friends i could invite.

Perhaps games can also be started after certain amount of time anyway.
If games are waiting to start for days, perhaps a time trigger could just start them without the required players.
Formerly playing the Nosferatus and Bhrantan Family.
Currently playing the Polytus Family in: Gotland, Madina, Astrum, Outer Tilog

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #24: April 14, 2016, 10:21:54 PM »
True, that would be useful. For the moment I can tell you it's just the three of us. If nobody else joins, I will start at least one game tomorrow, so we can proceed.

Nosferatus

  • Testers
  • Mighty Duke
  • *
  • Posts: 1093
  • Too weird to live, too rare to die
    • View Profile
Re: Alpha Client Feedback
« Reply #25: April 15, 2016, 11:14:10 AM »
two games started, yet i cant play them.
When i click play i go into the game and get a conncection refused error, all i can do is click dismiss or go back to main menu.
So i try again without my firewall enabled, this to no avail.
Clicking dismiss, brings me into the game, yet its so incredibly lagged that i cant test anything further.
I think there is a connection, but it might be very slow.
Formerly playing the Nosferatus and Bhrantan Family.
Currently playing the Polytus Family in: Gotland, Madina, Astrum, Outer Tilog

Tom

  • Administrator
  • Exalted Emperor
  • *
  • Posts: 8214
    • View Profile
    • BattleMaster
Re: Alpha Client Feedback
« Reply #26: April 15, 2016, 12:11:40 PM »
There should be no lag because there is no ongoing client-server communication. Can you describe what exactly you experience as lag?

James

  • BM Dev Team
  • Mighty Duke
  • *
  • Posts: 986
  • WARNING: Outer Tilog is different...
    • View Profile
Re: Alpha Client Feedback
« Reply #27: April 15, 2016, 12:17:50 PM »
Just tried playing one of the games, I started it in the wrong sized window (my fault) which meant I couldn't see the info at the bottom but when I had clicked a person, action, then square a red sphere appeared in the square (and after choosing build it said 'what' underneath). I then restarted in the hopes a smaller window would allow me to see all the options...

On restart, I can now see all the options, but when clicking build, etc, selecting a square no longer gives the red sphere and any of the options, after clicking on a square, show the detail below the family member as "-" rather than "build" or such.

*edit - it appears this issue is caused when going back into a game already started. When I started the other game, I was able to make all the selections, the actions are detailed under the family member, and the red spheres appear where I set the (non forest) actions to take place.
**edit2 - yes, restarted again, first game as initially described, second game had three family members still listed with actions (nothing marked on the grid now though) and the other family members were now shown as not doing anything and when then trying to allocate an action, the detail went to "-" as per the first game.
« Last Edit: April 15, 2016, 12:27:14 PM by James »
WARNING: Outer Tilog is different...

James

  • BM Dev Team
  • Mighty Duke
  • *
  • Posts: 986
  • WARNING: Outer Tilog is different...
    • View Profile
Re: Alpha Client Feedback
« Reply #28: April 15, 2016, 12:18:46 PM »
Also, a 'return to main menu' button would be useful, at the moment have to restart the client each time to swap between games.
WARNING: Outer Tilog is different...

James

  • BM Dev Team
  • Mighty Duke
  • *
  • Posts: 986
  • WARNING: Outer Tilog is different...
    • View Profile
Re: Alpha Client Feedback
« Reply #29: April 15, 2016, 12:19:45 PM »
...and I accidentally zoomed and scrolled when I pressed some keys. Can you let us know what keys do what? Thanks.
WARNING: Outer Tilog is different...